當白老鼠的下場

剛剛看到 WordPress 2.9 Release 的消息,雖然我現在對於新版本並不是那麼地熱衷,現在手上的 2.8.x 版本也沒什麼不滿意的地方。過去要升級新的版本,得要先去 WordPress 主站下載要升級的版本,解壓縮,然後在用 FTP 上傳到網站空間裡,要細緻一點的還得動用版本比對,然後用 Diff 跟 Patch 去升級。現在的升級是如此方便,網頁上一個按鈕按下去就幫你升級到好,我還是受不了誘惑按了下去。

然後悲劇就發生了。

Simple Tags can't work with this WordPress version !

Simple Tags can’t work with this WordPress version !

所有 Simple Tags 1.6.6 的相關功能目前都無法使用,包括標籤、相關文章等等。偏偏 2.9 這版雖然號稱有 “Global undo / Trash",但是還沒輕易到可以溯回到舊的版本。

現在要嘛就是等 Simple Tags 出新的版本可以支援 WordPress 2.9,要嘛就是花工夫自己用  WordPress 2.8 蓋回來 (不曉得資料庫這樣子有沒有問題)。

懶人如我,等吧。

Update: 在嗷嗷待哺等中餐的空檔, WordPress 討論區裡的一篇文章提供了鋸箭法,直接改 Simple Tags 的 source code, by pass versioin check:

If you edit the plugin via the editor interface, find this line (near the top):

if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false) {

and change it to

if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false || strpos($wp_version, '2.9') !== false ) {

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *

%d 位部落客按了讚: